Guiserver again

Started by jazper, April 17, 2016, 11:54:09 AM

Previous topic - Next topic


Hi all.  With a new installation of Ubuntu 15.04, I installed java (not the jre that comes with ubuntu) from Oracle, as shown in the downloads page.  The result is that the java executable is found at

I then created a link, with
Quotesudo ln -s /usr/bin/java/jre1.8.0_77/bin/java /usr/bin/java

This however does not find guiserver.jar when
is typed.  Am I linking incorrectly?  The newlisp executable is in /usr/local/bin


On OS X and all other Unix/Linux newlisp-edit looks for NEWLISPDIR/guiserver.jar, where NEWLISPDIR is defined as /usr/local/share/newlisp on newlisp startup, except when NEWLISPDIR  is already defined in the environment, then that definition is not changed when newlisp starts.

You also can start newlisp-edit by starting guiserver.jar first:

java -jar /usr/local/share/newlisp/guiserver.jar 64001 /usr/local/bin/newlisp-edit

or use 47011 or any other free portnumber greater 1024.

Ps: portno + 1 will also be used so for 64001, 64001 and 64002 will be used etc.


Thanks for the NEWLISPDIR tip.  I will try setting that. However, this java response has dogged me for days:  any attempt to call java results in this response in the terminal:
QuoteThe program 'java' can be found in the following packages:

* default-jre

* gcj-4.9-jre-headless

* gcj-5-jre-headless

* openjdk-7-jre-headless

* gcj-4.8-jre-headless

* openjdk-6-jre-headless

* openjdk-8-jre-headless

Try: sudo apt-get install <selected package>

I even tried it with these installed, with the same result.


Setting NEWLISPDIR does not help:

is what I do.

The java problem remains.


NEWLISPDIR does not persist.   I set it and restart, and it's not there using
Quoteprintenv NEWLISPDIR

There are a confusing number of totally different posts on askbuntu on how to set it on startup, (~/.profile, ~/.local.rc, ~/.pam_environment, and some files in /etc) all of which I have tried, and none work.  

Anyhow, even after setting it for a terminal session and checking that it still there, it doesn't change things


I was wrong about one thing:  the version.  I am on Ubuntu 15.10


This problem sorted itself out somehow.  I'm on Ubuntu 16.04.  I installed newLISP from the download.  After not getting the GuiServer to work, I left things for these few months, & had my newLISP fun on windows.  Then, I found a post on how to install Oracle Java on Ubuntu 16.04.  I followed that, & the guiserver just worked.  It was not necessary to create a symlink.