Dragonfly 0.70 Released!

Started by itistoday, March 22, 2010, 07:06:09 PM

Previous topic - Next topic


Finally! Here are the changes:

 * all code uses new ++,--,extend,write,read functions (still compatible with older newlisps)
  * added 'extract' and '<-' functions to core utils
  * Route.Resource has been updated with a 'catch-all' function.
  * added documentation for MAX_POST_LENGTH in request.lsp
  * $BINARY can now handle large data (compensated for a newLISP bug in 'read-buffer').
  * DF:activate-plugin can now be used to load all lisp files in a directory
  * db/database_utils includes for-query-with-db, assoc-row-with-db, query-cell-with-db and others
  * db/database_orm - DB.OBJ - a very simple ORM for DF.DB
  * db/database_sqlite3 updated to version 1.2 (see its docs for what's new)
  * fixed Jeff's JSON.lsp plugin (switched to " instead of ' for strings)
  * fixed bug in definition of define-smacro
  * Response:cookie now returns correct value (full cookie as list) when given only key

http://github.com/taoeffect/dragonfly-newlisp/downloads">Download 0.70 from here.

This version should be safe to use with the latest version of newLISP.

Also, Dragonfly has moved off Google Code, its official repository is now located on GitHub:


If you prefer using Mercurial (like I do), you can http://hg-git.github.com/">use this.
Get your Objective newLISP groove on.


The new DB stuff can be found here:

Get your Objective newLISP groove on.


Cool! I suppose it works well with 10.1 too.

I expect to upgrade when I get some time to examine the files which need updating.



Running on newLISP v.10.1.10:

ERR: symbol is protected in function define : (read source-string)
called from user defined function load-once
called from user defined function load-files-in-dir

Presumably that's due to:

(when (< (sys-info -2) 10111)
(constant (global 'term) name)
(constant (global 'read) read-buffer)
(constant (global 'write) write-buffer)

and I've defined read elsewhere?


Yes, most likely, as the stack trace suggests, you should search your project for "source-string" to try to find where you're using it.

These declarations were necessary to be compatible with the recent changes in newLISP.
Get your Objective newLISP groove on.


Yes - I've found it.

You have to laugh, really - I  tried to keep everything on 10.1 and I still got bitten by the not-yet-installed 10.2! :) Still, I like the way you tried to keep compatibility with 10.1 and 10.2.

I'll leave it alone for now - it will only become a problem when something upgrades to 10.2.... :(