reposted development newLISP v.9.2.5 for Intel Mac OS X

Started by Lutz, November 13, 2007, 03:23:20 PM

Previous topic - Next topic


This has been repackaged on Mac OS X, Tiger 10.4, but with a newlisp binary executable for Intel Mac, compiled on Mac OS X, Leopard 10.5. If this one has problems too on Intel iMacs running Tiger, than there seems to be some incompatibility between Intel binaries made on Leopard running on Tiger.

Please let me know if this package behaves better ;-)


ps: you may have to remove /Library/Receipts/newLISPpackage.pkg to reinstall


Sorry Lutz this still doesn't work for me. Still get 'bus error'.

I'm on an intel iMac running Tiger 10.4.10.

Should have given you this too:

Command: newlisp
Path:    /usr/local/bin/newlisp
Parent:  bash [5050]

Version: ??? (???)

PID:    2667
Thread: 0

Exception:  EXC_BAD_ACCESS (0x0001)
Codes:      KERN_PROTECTION_FAILURE (0x0002) at 0x00000000

Thread 0 Crashed:
0   libSystem.B.dylib 0x900026e4 getenv + 13
1   libSystem.B.dylib 0x90001b9c setlocale + 355
2   newlisp           0x0000198b 0x1000 + 2443
3   newlisp           0x0000cc71 0x1000 + 48241
4   newlisp           0x00001856 0x1000 + 2134

Thread 0 crashed with X86 Thread State (32-bit):
  eax: 0x00000000  ebx: 0x90001a4a  ecx: 0x90000fd8  edx: 0x00000008
  edi: 0x000000c0  esi: 0xa00020a0  ebp: 0xbffff8c8  esp: 0xbffff8a0
   ss: 0x0000001f  efl: 0x00010282  eip: 0x900026e4   cs: 0x00000017
   ds: 0x0000001f   es: 0x0000001f   fs: 0x00000000   gs: 0x00000037

Binary Images Description:
    0x1000 -    0x3afff newlisp /usr/local/bin/newlisp
0x8fe00000 - 0x8fe4afff dyld 46.12 /usr/lib/dyld
0x90000000 - 0x90171fff libSystem.B.dylib /usr/lib/libSystem.B.dylib
0x901c1000 - 0x901c3fff libmathCommon.A.dylib /usr/lib/system/libmathCommon.A.dylib
0x90bd2000 - 0x90bd9fff libgcc_s.1.dylib /usr/lib/libgcc_s.1.dylib
0x96498000 - 0x964c6fff libncurses.5.4.dylib /usr/lib/libncurses.5.4.dylib
0x9660e000 - 0x96620fff libedit.2.dylib /usr/lib/libedit.2.dylib


Thanks for the error dump.

I was hoping its the changed packager app. in Leopard, but it seems to be to be some backwards incompatibility for running Leopard 10.5 compiled binaries on on Tiger 10.4.

Unfortunately my Intel machines are running Leopard and I cannot go back because of the new Bootcamp support shipped in Leopard (I need this for Windows development).

I wonder if somebody can compile a newlisp Intel binary on Tiger 10.4? You need the Xcode package installed (from the Tiger install disk). then just do a:

tar xzvf newlisp-9.2.5.tgz
cd newlisp-9.2.5
make test

in your home directory and send the resulting newlisp binary to me, ;-). And I can test and package it.


ps: Jeff, aren't you on Mac OS X too, or did you already move to Leopard too?


I just see the following in Cormullion's error dump;

Command: newlisp
Path:    /usr/local/bin/newlisp

which is wrong, newLISP is installed in /usr/bin/newlisp

strange ...



Quote from: "Lutz"I wonder if somebody can compile a newlisp Intel binary on Tiger 10.4?

Done.  I just emailed it to you.  Let me know if it works out.  --Ricky
(λx. x x) (λx. x x)


Thanks Rick, just posted it again here:"> ... -intel.dmg">

also fine on Leopard, lets hope it works well for everybody else too ...